Linux、Solaris 查看硬件,系统信息


Solaris

硬盘光驱等信息
iostat -E
查到CPU,内存,总线,环境状态等信息
prtdiag -v
prtconf
内存
prtconf -vp | grep Mem
vmstat 1
echo ::memstat | mdb -k
prstat -a
kstat -m vmem
系统位数
/usr/bin/isainfo -kv
isainfo -b
isainfo -v
getconf LONG_BIT  //?有待验证
系统版本
uname -a
cat /etc/release
CPU
psrinfo -vp
mpstat 1
进程查端口:
pfiles pid|grep port
端口查进程:
cd /proc;for i in *; do echo ------ process $i ---------;pfiles $i|grep -i "port: 11223"; done  ##注意冒号后面有个空格
pargs -l 11343
ps -efo pmem,uid,pid,ppid,pcpu,comm | sort -r
查看进程完整参数:
/usr/ucb/ps -auxww
查看开机启动RC的日志
/var/svc/log/milestone-multi-user:default.log
/var/adm/messages
抓包:
snoop

linux

#查看服务器型号
dmidecode | grep "Product"
#查看CPU型号
dmidecode -t processor|grep Version
#查看内存大小
dmidecode -t memory|grep Size
#查看内存速度
dmidecode -t memory|grep Speed
#查看磁盘大小
fdisk -l|grep Disk
#查看硬盘温度
hddtemp /dev/sda
#查看CPU温度
sensors
#硬盘性能检查
dd if=/dev/zero of=/test/test1 bs=1M count=200     (一次写1M 写200次)

DD测试硬盘io

==测试磁盘的写入==

/usr/bin/time dd if=/dev/zero of=/tmp/foo bs=4k count=1024000
  • 这个命令时往磁盘的文件/tmp/foo中写入一个4G大小的文件,当然文件的内容全部是空字符了,同时用/usr/bin/time来对命令的执行进行计时,命令中的bs指的是写入文件时的块大小,
  • 其实就相当于Oracle中的block大小了,count是写入的块数。采取这种方法来写入数据时只是测试的连续读磁盘的性能,而不是随机读的性能,不能采取这种方法检查一个机器的IOPS的,只能检查磁盘的吞吐率。

==测试磁盘的读取==

/usr/bin/time dd if=/tmp/foo of=/dev/null bs=4k
  • 上面的命令是从/tmp/foo文件中读取数据,然后扔掉,这里bs用的是读取时块的大小。和上面写入的命令一样,这样测试的仅仅是最大的读取性能,而不是随机IO的性能。

==还能读写同时测试==

/usr/bin/time dd if=/tmp/foo of=/tmp/foo2 bs=4k
  • 在上面的命令中都用到了time命令对操作进行计时,这样才能正确的进行判断。要记住的一点是dd命令只能够提供一个大概的测试,通过这个简单的命令可以对磁盘系统的最大性能有一个大概的了解,要了解更详细的信息还要通过其他方法来查看。

==写入测试==

time dd if=/dev/zero of=/test.dbf bs=64k count=16k conv=fsync;rm -rvf /test.dbf
time dd if=/dev/zero of=/test.dbf bs=64k count=16k conv=fsync;rm -rvf /test.dbf
time dd if=/dev/zero of=/home/test.dbf bs=64k count=16k conv=fsync;rm -rvf /home/test.dbf

阿里云:35-55M/S
亚马逊:35-40M/S
Ucloud:50-100M/S (不稳定)
PC(SATA3):70--80M/S 
Seagate Barracuda 7200 SATA 3.0, 6.0 Gb/s ST1000DM003-1SB102  (184 MB/s)
KINGSTON SUV400S37240G SATA 3.1, 6.0 Gb/s  (460 MB/s)
CT240BX200SSD1 SATA 3.1, 6.0 Gb/s (440MB/s)
SAS:105-110M/S
15000转SAS:160-170M/S
hdparm -tT/dev/sda    //测试读取性能(硬盘读取,缓存读取)
#硬盘信息,健康检查
smartctl --all /dev/sda
smartctl -i -d ata /dev/sda //查看信息
smartctl -s on -d ata /dev/sda //开启SMART
smartctl -H -d ata /dev/sda //测试
#################
dmidecode
-q 或 --quiet 不显示太多信息,比如某条数据是从哪里读来的等等,为了得到简洁的信息,此条很有用。
-t 或 --type TYPE 指定要显示哪方面的内容,很重要,随后介绍。
-s 或 --string KEYWORD 显示特定的关键字,下面会有介绍。
-u 或 --dump 直接显示DMI表信息而不解码,将以16进制的文本方式显示,对普通用户意义不大。
1, 主板信息
.查看主板的序列号
--------------------------------------------------
#使用命令
dmidecode | grep -i 'serial number'
#查看板卡信息
cat /proc/pci
--------------------------------------------------
2, cpu信息
--------------------------------------------------
#通过/proc文件系统
1) cat /proc/cpuinfo
#通过查看开机信息
2) dmesg | grep -i 'cpu'
3)dmidecode -t processor
系统信息:
getconf LONG_BIT    //位数
uname -a //内核版本
lsb_release -a  //发型版本
--------------------------------------------------
3, 硬盘信息
--------------------------------------------------
#查看分区情况
fdisk -l
#查看大小情况
df -h
#查看使用情况
du -h
#hdparm -I /dev/sda
# hdparm -i /dev/hda     # 查看磁盘参数 
#dmesg | grep sda
#mount | column -t      # 查看挂接的分区状态
#swapon -s               # 查看所有交换分区
--------------------------------------------------
4, 内存信息
--------------------------------------------------
1) cat /proc/meminfo
2) dmesg | grep mem
3) free -m
4) vmstat
5) dmidecode -t memory
6) dmidecode | grep -i mem
--------------------------------------------------
5, 网卡信息
--------------------------------------------------
1) dmesg | grep -i 'eth'
2) cat /etc/sysconfig/hwconf | grep -i eth
3) lspci | grep -i 'eth'
mii-tool -v
ethtool eth0
ethtool -i eth0 //查看网卡驱动信息
--------------------------------------------------
6, 鼠标键盘和USB信息
查看键盘和鼠标:cat /proc/bus/input/devices
查看USB设备:cat /proc/bus/usb/devices
# lspci -tv               # 列出所有PCI设备
# lsusb -tv               # 列出所有USB设备
查看各设备的中断请求(IRQ):cat /proc/interrupts
7, 显卡信息
--------------------------------------------------
1)lspci |grep -i 'VGA'
2)dmesg | grep -i 'VGA'
--------------------------------------------------
8, 声卡信息
--------------------------------------------------
1)lspci |grep -i 'VGA'
2)dmesg | grep -i 'VGA'
--------------------------------------------------
7, 其他命令
.用硬件检测程序kuduz探测新硬件:service kudzu start ( or restart)
.dmesg (查看所有启动时检测到的硬件信息)
.lspci (显示外设信息, 如usb,网卡等信息)
.cat /etc/sysconfig/hwconf
.mpstat
8, 需要手动安装的工具
lshw,hwinfo,hal-device-manager

Solaris如何检测硬件参数

1).查看当前处理器的类型和速度(主频)
# psrinfo -v
Status of processor 1 as of: 11/24/01 10:34:41
Processor has been on-line since 11/24/01 10:18:20.
The sparcv9 processor operates at 432 MHz,
and has a sparcv9 floating point processor.
Status of processor 3 as of: 11/24/01 10:34:41
Processor has been on-line since 11/24/01 10:18:22.
The sparcv9 processor operates at 432 MHz,
and has a sparcv9 floating point processor.
2).打印当前的OBP版本号
# prtconf -V
OBP 3.20.0 2000/10/24 10:47
# /usr/platform/sun4u/sbin/prtdiag -v | grep OBP
OBP 3.20.0 2000/10/24 10:47 POST 6.1.0 2000/10/24 10:49
ok. .version
Release 3.20 Version 0 created 2000/10/24 10:47
OBP 3.20.0 2000/10/24 10:47
POST 6.1.0 2000/10/24 10:49
OBDIAG 4.5.1 2000/10/24 10:48
3).查看硬盘物理信息(vendor, RPM, Capacity)
# iostat -E
sd0 Soft Errors: 0 Hard Errors: 0 Transport Errors: 0
Vendor: SEAGATE Product: ST34371W SUN4.2G Revision: 7462 Serial No:
JDX394220KW EBC
Size: 4.29GB ;
Media Error: 0 Device Not Ready: 0 No Device: 0 Recoverable: 0
Illegal Request: 0 Predictive Failure Analysis: 0
sd2 Soft Errors: 0 Hard Errors: 0 Transport Errors: 0
Vendor: FUJITSU Product: MAJ3364M SUN36G Revision: 0804 Serial No: 01M18144
Size: 36.42GB ;
Media Error: 0 Device Not Ready: 0 No Device: 0 Recoverable: 0
Illegal Request: 0 Predictive Failure Analysis: 0
sd3 Soft Errors: 0 Hard Errors: 0 Transport Errors: 0
Vendor: FUJITSU Product: MAJ3364M SUN36G Revision: 0804 Serial No: 01M16199
Size: 36.42GB ;
Media Error: 0 Device Not Ready: 0 No Device: 0 Recoverable: 0
Illegal Request: 0 Predictive Failure Analysis: 0
sd21 Soft Errors: 0 Hard Errors: 0 Transport Errors: 0
Vendor: TOSHIBA Product: DVD-ROM SD-M1401 Revision: 1007 Serial No: 06/22/00
Size: 18446744073.71GB ;
Media Error: 0 Device Not Ready: 0 No Device: 0 Recoverable: 0
Illegal Request: 0 Predictive Failure Analysis: 0
4).查看磁盘的几何参数和分区信息
# prtvtoc /dev/rdsk/c0t0d0s0
* /dev/rdsk/c0t0d0s0 partition map
*
* Dimensions:
* 512 bytes/sector
* 135 sectors/track
* 16 tracks/cylinder
* 2160 sectors/cylinder
* 3882 cylinders
* 3880 accessible cylinders
*
* Flags:
* 1: unmountable
* 10: read-only
*
* Unallocated space:
* First Sector Last
* Sector Count Sector
* 8277120 103680 8380799
*
* First Sector Last
* Partition Tag Flags Sector Count Sector Mount Directory
0 2 00 0 2049840 2049839 /
1 3 01 2049840 615600 2665439
2 5 00 0 8380800 8380799
5 0 00 2665440 2458080 5123519 /opt
6 4 00 5123520 3073680 8197199 /usr
7 8 00 8197200 79920 8277119 /export/home
5).显示已经使用和未使用的i-node数目
# df -F ufs -o i
Filesystem iused ifree %iused Mounted on
/dev/dsk/c0t0d0s0 7859 479821 2% /
/dev/dsk/c0t0d0s6 37763 339517 10% /usr
/dev/dsk/c0t0d0s5 722 301102 0% /opt
/dev/dsk/c0t0d0s7 4 24380 0% /export/home
6).显示cpu使用率最高的进程
# ps -eo pid,pcpu,args | sort 1n
该命令输出当前系统进程的pid, CPU占用率及命令描述,并以pcpu来排序
7).显示内存占用率最高的进程
# ps -eo pid,vsz,args | sort 1n
该命令输出当前系统进程的pid,内存占用率及命令描述,并以vsz来排序
8).查看及启动系统的32位或64位内核模式
64位模式
# isalist -v
sparcv9 vis sparcv9 sparcv8plus vis sparcv8plus sparcv8 sparcv8-fsmuld sparcv7
sparc
# isainfo -v
64-bit sparcv9 applications
32-bit sparc applications
# isainfo -b
64
启动64位内核模式
ok. boot kernel/sparcv9/unix
32位模式
# isalist -v
sparcv8plus vis sparcv8plus sparcv8 sparcv8-fsmuld sparcv7 sparc
# isainfo -v
32-bit sparc applications
# isainfo -b
32
启动32位模式
ok. boot kernel/unix
9).查看当前的OpenWindows版本
# showrev -w
OpenWindows version:
X11 Version 6.4.1 5 November 2001
10).查看当前CDE的版本
# /usr/ccs/bin/what /usr/dt/bin/dtmail
/usr/dt/bin/dtmail:
CDE Version 1.4.6_06
CDEVersion1.4.6_06
11).测定当前的显示器刷新频率
/usr/sbin/ffbconfig -rev ?
Valid values for -res option are:
1024x768x60 [1]
1024x768x70 [1]
1024x768x75 [1] [2]
1024x768x77
1024x800x84
1152x900x66
1152x900x76
1280x800x76 [1] [2]
1280x1024x60 [1] [2]
1280x1024x67
1280x1024x76
1280x1024x85 [1] [2]
960x680x112s
960x680x108s
640x480x60 [1] [2]
640x480x60i [1]
768x575x50i [1]
1440x900x76 [1] [2]
1600x1000x66 [1] [2]
1600x1000x76 [1] [2]
1600x1280x76 [1] [2]
1920x1080x72 [1] [2]
1920x1080x76 [1] [2]
1920x1200x70 [1] [2]
1920x1200x75 [1] [2]
svga [1]
1152
1280
stereo
vga [1] [2]
ntsc [1]
pal [1]
none
Notes:
[1] monitor does not support this resolution.
[2] this version of FFB (FFB1) does not support this resolution
12).查看系统配置
# /usr/platform/sun4u/sbin/prtdiag -v
System Configuration: Sun Microsystems sun4u Sun Enterprise 450 (2 X
UltraSPAR
C-II 432MHz)
System clock frequency: 86 MHz
Memory size: 1024 Megabytes
========================= CPUs =========================
Run Ecache CPU CPU
Brd CPU Module MHz MB Impl. Mask
--More--
--- --- ------- ----- ------ ------ ----
SYS 1 1 432 4.0 US-II 10.0
SYS 3 3 432 4.0 US-II 10.0
========================= Memory =========================
Interlv. Socket Size
Bank Group Name (MB) Status
---- ----- ------ ---- ------
0 none 1901 256 OK
0 none 1902 256 OK
0 none 1903 256 OK
0 none 1904 256 OK
0 none 1701 256 OK
0 none 1702 256 OK
========================= IO Cards =========================
No failures found in System
===========================
========================= Environmental Status =========================
System Temperatures (Celsius):
------------------------------
AMBIENT 20
CPU 1 40
CPU 3 40
=================================
Front Status Panel:
-------------------
Keyswitch position is in On mode.
System LED Status: POWER GENERAL ERROR ACTIVITY
[ ON] [OFF] [ ON]
DISK ERROR THERMAL ERROR POWER SUPPLY ERROR
[OFF] [OFF] [OFF]
Disk LED Status: OK = GREEN ERROR = YELLOW
DISK 2: [OK] DISK 3: [OK]
DISK 0: [OK] DISK 1: [EMPTY]
=================================
Fans:
-----
Fan Bank Speed Status
-------- ----- ------
CPU 49 OK
PWR 31 OK
Power Supplies:
---------------
Supply Rating Temp Status
------ ------ ---- ------
0 550 W 33 OK
1 550 W 33 OK
========================= HW Revisions =========================
ASIC Revisions:
---------------
STP2223BGA: Rev 4
STP2223BGA: Rev 4
STP2223BGA: Rev 4
STP2003QFP: Rev 1
STP2205BGA: Rev 1
System PROM revisions:
----------------------
OBP 3.20.0 2000/10/24 10:47 POST 6.1.0 2000/10/24 10:49
# sysdef
*
* Hostid
*
80fee99b
*
* sun4u Configuration
*
*
* Devices
*
packages (driver not attached)
terminal-emulator (driver not attached)
deblocker (driver not attached)
obp-tftp (driver not attached)
disk-label (driver not attached)
SUNW,builtin-drivers (driver not attached)
sun-keyboard (driver not attached)
ufs-file-system (driver not attached)
chosen (driver not attached)
openprom (driver not attached)
client-services (driver not attached)
options, instance #0
aliases (driver not attached)
memory (driver not attached)
virtual-memory (driver not attached)
associations (driver not attached)
slot2disk (driver not attached)
slot2led (driver not attached)
slot2dev (driver not attached)
pci, instance #0
ebus, instance #0
auxio (driver not attached)
……
# prtconf -D
System Configuration: Sun Microsystems sun4u
Memory size: 1024 Megabytes
System Peripherals (Software Nodes):
SUNW,Ultra-4
packages
terminal-emulator
deblocker
obp-tftp
disk-label
SUNW,builtin-drivers
sun-keyboard
ufs-file-system
chosen
openprom
client-services
options, instance #0 (driver name: options)
aliases
memory
virtual-memory
associations
slot2disk
slot2led
slot2dev
pci, instance #0 (driver name: pcipsy)
ebus, instance #0 (driver name: ebus)
auxio
power (driver name: power)
SUNW,pll
sc
se, instance #0 (driver name: se)
su, instance #0 (driver name: su)
…..
13).查看当前系统中已经应用的补丁
# showrev -p
Patch: 109618-01 Obsoletes: Requires: Incompatibles: Packages: SUNWeuxwe,
SUN
Weuezt, SUNWeudlg, SUNWeudda
Patch: 109889-01 Obsoletes: 109353-04 Requires: Incompatibles: Packages:
SUNWk
vmx, SUNWkvm, SUNWmdb, SUNWhea, SUNWpstl, SUNWpstlx
Patch: 110369-05 Obsoletes: 110709-02 Requires: Incompatibles: Packages:
SUNWk
vmx, SUNWcarx, SUNWcsr
Patch: 110370-03 Obsoletes: 111643-01 Requires: Incompatibles: Packages:
SUNWk
vmx, SUNWkvm, SUNWmdb, SUNWhea, SUNWpstl, SUNWpstlx
Patch: 110373-04 Obsoletes: 111508-01 Requires: Incompatibles: Packages:
SUNWk
vmx, SUNWcarx, SUNWcsr
Patch: 110374-08 Obsoletes: 110136-02, 110516-02 Requires: Incompatibles:
Pack
ages: SUNWkvmx, SUNWcarx, SUNWcar, SUNWcsr, SUNWmdbx
…..
14).显示当前的运行级别
# who -rH
NAME LINE TIME IDLE PID COMMENTS
. run-level 3 Nov 24 10:18 3 0 S
15).查找一个文件所从属的包
# pkgchk -lp /usr/lib/sendmail
Pathname: /usr/lib/sendmail
Type: regular file
Expected mode: 4555
Expected owner: root
Expected group: bin
Expected file size (bytes): 761368
Expected sum(1) of contents: 41707
Expected last modification: Sep 24 03:13:13 2001
Referenced by the following packages:
SUNWsndmu
Current status: installed
16).查看当前的bind版本信息
# nslookup -class=chaos -q=txt version.bind
Server: ns.lnpta.net.cn
Address: 202.96.64.68